Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
any idea why the interiors won't render?
#1
So far I've come across 3 houses where the interiors don't render at all.

the portals appear work fine including the windows which DO render properly, the collision files (floors, walls, pillars, or whatever you might have to collide with inside) seem to work fine work fine, the cells seems to be properly defined, you can teleport into and out of it, the exteriors render properly, and "some" of the interior's will render but they're spotty at best.

I get no lockups or crash to desktops, but I get grey nothing for the walls and camera tends to warp outside the structure even tho my player won't.

any idea's where to look? I've given the msh files a once over but I'm not seeing anything poping out as obviously different from the house meshes that DO work... It's almost like the cell is painting the walls inside out...

Just a shot in the dark to see if somebody has something that might get me something to go on.

thanks,
Duff.
 
Reply
#2
Ok, if nobody knows or has a hint for me, can someone point me to a program that will allow me to create 3d points and render the triangles? I have a legal copy of Lightwave3d (which includes modeler) but I haven't used it in 5+ years LOL... If there's a program that's easier to use maybe I could start ploting points (verts) and trying to interpret the indx triangles to see where I might be running into my problem.
 
Reply
#3
ok, so when you enter a building with the bug, your character definately collides at the extents of the cell. but the camera is allowed to soom out past the walls and does not collide with the walls themselves.

I'm guessing from my days working with Lightwave, that the interrior walls are being built backwards. so for instance, as I recall in LW Modeler, if you selected your points in one direction, then said make polygon, then it it would automatically set the surface of the polygon to be visible from one side, but you'd see nothing but the points and poly outline from the other side. so you didn't get a two faced polygon unless you selected the points again in the opposite order and made a new polygon, giving the object two polygons with the same points...

I'm may be way off on this but it seems like a similar problem. My issue is that I don't know if that's a problem with the mesh, or the LOD or with the POB... I'm guessing it's the mesh since the cell is working without any crashes. I'm not exactly what the LOD does other than tell it what meshes to load. so...

anyone out there shed some light on this?
 
Reply
#4
Just a thought if your using the consolidated tre's, would it be because some older files are not rendering properly with the newer structures....

I'm probably way off, but, I'm playing catch up with your guides....

Which are ace btwSmile
 
Reply
#5
No idea what you did to break it, I have ported every house into the pre-cu client and not once ran into an issue like this.
[Image: 2156b479.gif]
 
Reply
#6
   
*edited*

lasko, I've looked into it both prior to your post and just this morning. right now I'm loading the TOC data strait up with the ONLY edit being the lod file change to 0007 from 0008. (I get CDT if I don't). still no goodness. :-(

it's either that a file needs to be edited that hasn't been, or I'm missing a file. I've been over the files with a Hex editor and Can't find anything I'm missing thus far... *shrug*

I'm about to give up on this one and go back to core scripting... Someone else will figure it out and post it before we hit 1.0 i'm sure. and if not then my repack just won't have that house. LOL... either way I gotta move on before I get burned out and quit altogether.

-Duff
 
Reply
#7
./shrug


Attached Files Thumbnail(s)
   
[Image: 2156b479.gif]
 
Reply
#8
Tbh, start over, or reverse your progress, see if you screwed up somewhere.
 
Reply
#9
yeah, hail mary time... :-) If not then I'll spam Uli's PM inbox until I get it right. LOL... it's silly tho because these structures that aren't working aren't really that great anyway. :-)

-Duff
 
Reply
#10
Haha yeah, Uli showed me the texture it uses for the ceiling. Straight up 'what...', but for me it's always just getting it right, even if I don't want it in the end.

I'd love to help, but I really have zero clue about any of that stuff, been keeping busy with .prt files lately, which has been taking up way too much time.

Speaking of which, I doubt I'll publicly release an object .iff editor, at least a full one, due to some stuff I found. I looked into it and have them worked out 'for the most part'.

I can help ya out if ya ever need help with any them, though.
 
Reply
  



Forum Jump:


Browsing: 1 Guest(s)