Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Classic BARC speeder assets patch
#1
Attached in the TRE are the files necessary client files to use the classic BARC speeder on a Core3-based SWG server.

Only parts missing are the STF additions for the actual deed title, and the description text when examining. Just need to add the appropriate LUA entries (use the Swoop as an example of what files you need to edit/add on the server side.)

I can provide the server-LUA if anyone needs it, but that part is the easy part of this. (imho)

NOTE: The files are the Publish 15 version of the BARC not NGE. (thus no bit-twiddling was required to make any of the files work). I also started with a Pub 14.1 object_template_crc_string_table file and added the entry to it rather than using the Pub 15 or later versions that include way more than I want)

TRE was packed using TreEdit 1.0


Attached Files
.tre   classic_barc_speeder.tre (Size: 2.38 MB / Downloads: 101)
 
Reply
#2
nice. I'll have to try it out when I get my dev environment back up to speed. :-) I miss my Barc and atpt.
 
Reply
#3
(2013-12-09, 09:25 AM)kinshi Wrote: I can provide the server-LUA if anyone needs it, but that part is the easy part of this. (imho)

EDIT:

OK, I have been able to get the mod to "work" by editing the following files:

object/intangible/vehicle/objects.lua
object/intangible/vehicle/serverobjects.lua
object/intangible/vehicle/barc_speeder_pcd.lua

object/mobile/vehicle/objects.lua
object/mobile/vehicle/barc_speeder.lua
object/mobile/vehicle/serverobjects.lua

object/tangible/deed/vehicle_deed/objects.lua
object/tangible/deed/vehicle_deed/serverobjects.lua
object/tangible/deed/vehicle_deed/barc_speeder_deed.lua

Kinshi has conveniently made these files (and all his scripts) available here.

However, the model and the sounds don't actually exist in the client, despite the TRE file loading correctly. I can mount and ride the barc using the /target and /mount commands, but it's invisible (and it plays the generic "spread legs" mount animation). I tried unpacking and repacking the supplied TRE with another that I know works and the result is the same - the parts of TRE that are mine work, so it's being loaded by the client OK, but BARC is still not working.

Any thoughts on what's happening here?

-----------

Edit:

Liakhara was kind enough to have a look at some of the files included in Kinshi's TRE and found some were missing values related to the BARC. With this information, I managed to build a functioning replacement TRE file using the Tarkin server files and Eastwind's Swoop2Barc mod. Thanks to Eastwind, this also fixes the holding a weapon mounted bug. You can download the replacement file here, classic_barc_speeder_fix.tre (updated to include the proper BARC sounds that work!).

Thank you to everyone who helped on the Mod the Galaxy and Tarkin IRC channels! I now have a much better idea of what goes into adding brand new an item to the game. Quite a lot of work! But, worth it. Smile

------------

Note: I tried a lot of things to get the customization kits to work with this, but no go. At the moment, the only way I know of to get a custom colored BARC is to use Eastwind's Swoop2Barc mod.
Legend of Hondo - A Single Player SWGEmu based ... science project? Smile
My SWGs Files - https://mega.nz/#F!nUMwRSAI!S35daVC46CcEX9PQKmWr-g
http://www.tpot.ca - SWG Mods and Information

 
Reply
#4
What was wrong with the files. Can you be more specific?
 
Reply
#5
What file is missing that causes the "spread legs" mount animation, your download link no longer works.
 
Reply
#6
datatables/mount/
the only 4 files in there control that
 
Reply
#7
Have them from CU files and he ride "spread legs" mount animation.
 
Reply
#8
think its all_b.lat or so
 
Reply
#9
Have a look on it, ported BARC from ULI's vehicle mods I got during May 2012. I had to add it server side as well and it works fine.

.tre   patch_ulidig_vehicles.tre (Size: 20.35 MB / Downloads: 54)
 
Reply
  



Forum Jump:


Browsing: 1 Guest(s)