Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
creating new mobile
#1
Hi there, just registered here and its a great site!
I'm sorry if this is the wrong place for this, but I'm seeking some assistance.

I'm working in learning some coding etc.. with the hopes of doing some server modding etc.. in the future.

I've started simple, modifying the mobile .lua files to change loot drops, chances, HAM etc.. of currently existing mobs.
i've worked out how to create new loot groups etc.. (again, with existing items)
now I'm trying to create a new mobile (again, using existing models, need to be able to do this before I can start looking into using post 14.1 stuff!)

To begin with, I copied a basic mob and adjusted its name etc..
I used a Chuba template and adjusted it to create a ChubaChuba
this is the chubachuba.lua file i created in the scripts\mobile\naboo folder

Code:
chubachuba = Creature:new {
    objectName = "@mob/creature_names:chubachuba",
    socialGroup = "chuba",
    faction = "",
    level = 5,
    chanceHit = 0.25,
    damageMin = 45,
    damageMax = 50,
    baseXp = 85,
    baseHAM = 135,
    baseHAMmax = 165,
    armor = 0,
    resists = {0,0,0,0,0,0,0,-1,-1},
    meatType = "meat_herbivore",
    meatAmount = 5,
    hideType = "hide_leathery",
    hideAmount = 3,
    boneType = "",
    boneAmount = 0,
    milk = 0,
    tamingChance = 0.25,
    ferocity = 0,
    pvpBitmask = ATTACKABLE,
    creatureBitmask = HERD,
    optionsBitmask = 128,
    diet = HERBIVORE,

    templates = {"object/mobile/chuba_hue.iff"},
    controlDeviceTemplate = "object/intangible/pet/chuba_hue.iff",
    lootGroups = {},
    weapons = {},
    conversationTemplate = "",
    attacks = {
    }
}

CreatureTemplates:addCreatureTemplate(chubachuba, "chubachuba")

I then edited the scripts\object\mobile\serverobjects.lua file and added the line

Code:
includeFile("mobile/naboo/chubachuba.lua")

so far this isnt working, I'm guessing there are other files I need to alter in order to get the new mobile recognised, any help anyone can offer woudl be great!
 
Reply
#2
Did you try to use /createCreature and see if it would generate?
ie: /createCreature chubachuba
Do you get the System Message that you were unable to spawn the creature or does nothing happen? Does it spawn but maybe it's invisible?

Need a bit more information about what you've got going on! Smile
Viaron
 
Reply
#3
thanks for the reply!

Nothing spawned, i did get an error in the console, 'invalid template' or similar.
When I get home I'll fire up the environment and get the exact details.
 
Reply
#4
Got a chance to test this again
Managed to corrupt my install somehow so had to do a fresh restart
did everything again and this time it worked fine!
Must have had some syntax or typo error I missed
 
Reply
#5
Glad to hear you got everything working! Smile
Viaron
 
Reply
  



Forum Jump:


Browsing: 1 Guest(s)