Hello There, Guest! Login Register


Thread Rating:
  • 1 Vote(s) - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Help] Can't extract the "SWGEmu Settings Overrider 1.5exe"
#1
Sad 
I have downloaded the SWGEmu Settings Overrider 1.5 (a Z7 file). When I use the 7-Zip to "open archive", it shows me a folder (known as "SWGEmu Settings Overrider 1.5"), and inside that folder contains two things: "MSCOMCTL.OCX" and "SWGEmu Settings Overrider 1.5.exe".

With the 7-Zip, I intent to extract this Z7 file, but every time when I do so, the result I only get is that get the folder with just the "MSCOMCTL.OCX", which means the .exe does not. Even though the 7-Zip does shows me that the .exe is indeed there, it doesn't come out for some reason. Huh

I tried to extract this .exe by others means such as copying or moving to a location, but I get different error messages, such as "Can not open output file : Access is denied" or "Not implemented (twice the time)". I also (still using the 7-Zip) tried to simply open it, but I get another error message that doesn't even makes sense what it says. Confused

I got these quotes back from SWGEmu forums, from this thread (page 11)

Kayliaah;293570 Wrote:I don't know if the old links still work so I uploaded it to my MF account, at least it'll stay here.
Repacked the exe with MSCOMCTL.OCX because some people seem to get an error message saying that they don't have it.

http://www.mediafire.com/?815mk9w2jl38qhp


-BoneZ-;293607 Wrote:Make sure you're using 7zip. If you're still having problems, try downloading it again. The file from her link works fine.

Despite these posts, I'm still having problems no matter how many times I download and use it with 7-Zip.

I suggest for you to take at look at this thread as well, just in case.


So anyway, I'm not sure what else I could think of to solve this. I do know what to do with this mod after reading the instruction (at least I think so). The problem is I cannot simply use this mod without getting this .exe to make it work. Perhaps I am doing something wrong?

I will greatly appreciate to does who can help me on this. One of my characters is a Master Ranger, so this is something I will surely love to have this mod work when going into the wilderness.
 
Reply
#2
Your anti-virus is probably deleting it - I had the same issue. So you extract, it works, then the AV immediately deletes the .exe file.

Edit: This one might actually be a virus - it comes up as Trojan: Runsas!plock, which seems not so good. That said, it might be a false positive. If you wait a bit I will be trying to make a new (clean) trainer for this soon.
 
Reply
#3
Unsure if that's the original file, but the original was made by Uli (Staff here and at the time staff at SWGEmu). It's super old and showed as a false positive back then too, but yeah, overall it should work.

That said, you can use SIE and my templates (I think I released these specific ones in public) and edit "swgemu_machineoptions.iff" yourself manually, just need to find the right things that you want to modify. The 2.0 version of his overrider basically did just that.

P.S. I've said this throughout the year, but hope to finally, soon, after SIE, be able to release my ModTheGalaxy Toolbox, which will cover the things that were in Uli's Overrider and much more.
 
Reply
#4
Now that n00854180t mentioned about the anti-virus, he or she may very well be right.

I just recently used another of my computer to see whether problem still persist. It does, but a bit different than the other. I'm going to use the terms #1 and #2 to refer specifically which computer I'm talking about.

I've already mentioned about my computer #1, but now I'm reporting that, when I extract this .exe, it doesn't get the error message this time, but knowing the location where I trying to place, the .exe doesn't appear at all. Perhaps my anti-virus stops this before it can even finish executing.

As for my computer #2, at first it does successfully extract the .exe and stayed there for a moment. I even successfully open the .exe without any problem. I copied this .exe to my USB so I can pass this to my #1, but when I open my USB from there, is suddenly gone. Went back to my #2 to try again (while is still there), but this time I get the message that the .exe "cannot be found", and then it vanish. Went to extract again the .exe the way I did, but now every time when doing so, the .exe appears, and suddenly... vanished Confused ! This now repeats every time when I extract the .exe.

I also discovered that I can still open this .exe while it's still inside of this Z7 file when using 7-Zip, but that's only on my #2. On my #1, as explained in my first post (third paragraph), it does not and I get this senseless error message.



As for Timbab: Forgive my ignorance, but I don't know what is this SIE you speak of Confused , though I have seen the "swgemu_machineoptions.iff" in my directory file and noticed that it has to do with it. Can you please tell me or show me the link(s) of what you're referring the SIE and your templates?

As for the 2.0 version, I once tried to download it, but the MediaFire website is not only warning me about the danger of this file (even though I read the posts saying that it was just a false alarm) but also not letting me to download at all. Part of the message says this: "For your protection, MediaFire does not enable distribution of dangerous files". Even if I wanted to accept the risk, I don't see any way to simply bypass this to begin downloading. That's one of the reasons why I went for the 1.5 version.
 
Reply
#5
SIE is this: http://www.modthegalaxy.com/forums/thread-sie-3-6

Idea is to be a complete modding suite for SWG by Sytner and myself. It'll get a big update soon but would work for this easily now.

You can grab the template here, it's the one called 'Templates - MachineOptions IFF', you'll need to put the .txt files into the 'templates' folder inside of SIE.

It's basically an option file that lets you set the view distance for numerous things and what not.

Example screenshot of the file:

[Image: PkClbsu.png]
 
Reply
#6
(2016-12-23, 09:58 PM)Timbab Wrote: Idea is to be a complete modding suite for SWG by Sytner and myself. It'll get a big update soon but would work for this easily now.
Interesting to hear about this ^^. It sure sounds like worth it to check it out when the time comes.

As we speak, I did successfully download this SIE (as well as requirements), and followed the instruction.


(2016-12-23, 09:58 PM)Timbab Wrote: You can grab the template here, it's the one called 'Templates - MachineOptions IFF', you'll need to put the .txt files into the 'templates' folder inside of SIE.
Um, I'm a little confuse in this part. When I click this link you posted, the file said 'Combined Template'. Nevertheless, I download it, but when I open your template using 7-Zip, I see that it contains folders containing .txt files that looks quite the same as it already comes in the templates folder inside of SIE, and I don't see this 'Templates - MachineOptions IFF' you mentioned. Perhaps I'm suppose to extract the .txt files from your downloaded templates as a replacement to the other .txt files already in the templates folder in SIE?



Speaking of 'swgemu_machineoptions.iff', I open that file from my main SWGEmu directory...if that is that I'm suppose to do after installing SIE. When I did, it shows me exactly like your screenshoot.

However, suddenly something went wrong. When I open this very same file for about the fourth time or so, I'm now getting the error message saying 'Access to path 'C:\Program Files (x86)\SWGEmu\SWGEmu\swgemu_machineoptions.iff.iff' is denied.' (that's how I located my main directory from my #1 computer). I don't know if this second extra '.iff' is the cause, as I still see this file called exactly as 'swgemu_machineoptions.iff' in my main directory. I have not make any change at all as I carefully explore inside this file with the SIE I recently installed, and never save anything just before I close this program. Although, when I open this same file after I locate elsewhere, such as my desktop, I can once again open this file in the way like your screenshoot, but still cannot do so from my main directory folder for some reason. Confused
 
Reply
#7
Sorry linked the wrong link for templates. This one should be it.

Also forgot that most of the templates were included in the latest SIE release, but by the look, you still need to grab the one I just linked.

Huh, hm, that sounds weird with the double .iff. I'd have said it was a Windows permission issue, but you said you opened it successfully before. But, oh, yeah, might be a permission issue afterall, since you can open them from the Desktop just fine.

But yeah, hope that does the trick with the template(s) I just linked and at least editing it from the desktop if you don't fix your Windows permissions to that folder or run SIE as Admin, just make sure you move the file back obviously after saving, if working off the Desktop or elsewhere. Tongue

P.S. Glad to hear that you didn't have any issues getting SIE setup, some people have had some issues as of late.
 
Reply
#8
(2016-12-24, 04:03 AM)Timbab Wrote: Sorry linked the wrong link for templates. This one should be it.

Also forgot that most of the templates were included in the latest SIE release, but by the look, you still need to grab the one I just linked.

Ah! That explained. Now I have successfully downloaded the 'Templates - MachineOptions IFF'. Smile

When I opened this file with 7-Zip, I found four .txt files:

OPTN_0002_BOOL.txt
OPTN_0002_FLT.txt
OPTN_0002_INT.txt
OPTN_0002_STDS.txt

I have extracted these four files directly to the 'Templates' folder inside of SIE as instructed -- that is if I understood correctly.


(2016-12-24, 04:03 AM)Timbab Wrote: Huh, hm, that sounds weird with the double .iff. I'd have said it was a Windows permission issue, but you said you opened it successfully before. But, oh, yeah, might be a permission issue afterall, since you can open them from the Desktop just fine.

But yeah, hope that does the trick with the template(s) I just linked and at least editing it from the desktop if you don't fix your Windows permissions to that folder or run SIE as Admin, just make sure you move the file back obviously after saving, if working off the Desktop or elsewhere.

Yes. I believe so as well. It may very well indeed be a permission issue, and this isn't the first time it happened to me when I have to replace an original file with the same, yet edited file in order to bypass this. As an example for one mod called 'Sytner's Satellite Maps 2.0', I have to move 'swgemu_live' to somewhere where I can edit it as instructed, save this file, and them move back to the main directory folder as a replacement  -- that's how I manage to get this mod to work for me.



Now that I have the SIE ready to operate, the next simple question is this: Now what?

Though I'm aware of this guide, but it looks pretty too complex to understand Confused . It has details or examples that probably is in general in terms of how to use it. Perhaps you can guide me or give me examples on how to use it? As you know, I'm interested in setting the viewing distance much farther, to see many trees and buildings from a very large distance, much like these screenshots.
 
Reply
#9
BTW guys, re why I said that it might indeed be a virus in the linked SWG Settings Overrider. That particular link is showing up as Rundas!plock, which is an actual trojan, for me.

False positives usually show up as something like HackTool.CheatEngine or HackTool.MemEditor or something like that - I have a copy of the Settings Overrider which doesn't actually set off the AV at all, but it doesn't work, probably because the offsets have likely changed (maybe due to the multiple instance support).

====

Regarding making a client-file mod to do the same thing, I'll try and see if I can make it work with your tips Smile I tried doing it myself by editing ui_options.inc but it didn't do the trick.
 
Reply
#10
(2016-12-26, 09:29 AM)n00854180t Wrote: BTW guys, re why I said that it might indeed be a virus in the linked SWG Settings Overrider. That particular link is showing up as Rundas!plock, which is an actual trojan, for me.

False positives usually show up as something like HackTool.CheatEngine or HackTool.MemEditor or something like that - I have a copy of the Settings Overrider which doesn't actually set off the AV at all, but it doesn't work, probably because the offsets have likely changed (maybe due to the multiple instance support).

====

Regarding making a client-file mod to do the same thing, I'll try and see if I can make it work with your tips Smile I tried doing it myself by editing ui_options.inc but it didn't do the trick.

Wow! I just made a research about this "Rundas!plock" you mentioned. What I found about this Trojan is that it is "new", and also annoying and dangerous! For some reason, as I mentioned in my second post, MediaFire was not letting me to download version 2.0 because it was deemed dangerous despite reports that it may very well be false alarm, yet it wasn't stopping me to download the 1.5 version every time.

I also would like to update my report about my computers, #1 and #2. Both of them are now clearly behaving exactly the same as each other, now seeing exactly what you were describing in your first post. Indeed, you are getting extremely close, if not close enough, to pinpoint the exact cause of this problem.

Could this means that, even though the files was uploaded by someone that can be trusted, can be infected somehow? Maybe when time pass by? If so, I guess many people like me cannot or should not download this file from a point when it all started, until it can be resolved. Is there, perhaps, other places where you can safely download the Overrider version 1.5 without risking getting a Trojan or other threats?

I'm still open to go for SIE, if that's the best and safest alternative way. But, as I said in my last post, I don't really know where or how to get started.
 
Reply
  



Forum Jump:


Browsing: 1 Guest(s)