Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No more tokens tcg_structure_deed_dinner
#1
Followed instructions in how to put those NGE structures with this guide :

http://www.modthegalaxy.com/forums/threa...g-to-core3

But happens some errors, what means that token error thing on dinner?

   

I search for solutions but i dont see anything about barn / dinner , just the only two things im planning to add. Few people like ? there is a lot of info about other things :/ well thnx for your time, im just start touching code few days ago and im really noob on that. ( i manage to add new planets, populated, place things, resources... but this thing its killme ) 

My english is bad, sorry for misspelling things or etc...
 
Reply
#2
change objectName in the iff to like objectname..item_n..diner or something of the sort. if you don't you will get token error
 
Reply
#3
(2016-01-15, 11:29 PM)Phoenix Wrote: change objectName in the iff to like objectname..item_n..diner or something of the sort. if you don't you will get token error

yeah this is what i thought its happening... because i see that tcg_ thing and i changed in SIE but i use SIE without any template that i see it fits well to change those names in all .iff. So i only change 2 entries with that TCG_ thing, because i dont see any more, and still happens. I save etc... ill try again now, now i know what means that token thing, thnx! Smile

I can change the 0010 to 0007 becuase its really easy to spot but the other things....
 
Reply
#4
Loading snapshot objects: [2300] / [?] (58 s) [SpawnAreaMap corellia] loading spawn areas...
Loading snapshot objects: [13720] / [?] (74 s) [ObjectManager] ERROR - creating object unknown gameObjectType 514
(74 s) [ObjectManager] ERROR - could not create object CRC = 0xdbbb0f39 template:object/building/player/player_house_tatooine_small_style_01.iff
core3: ../../../../MMOEngine/include/system/lang/ref/Reference.h:132: O sys::lang::Reference<O>::operator->() const [with O = server::zone::objects:Confusedcene::SceneObject*]: Assertion `obj != __null' failed.



Fixed the tgc thing, but then this, its strange because i doesnt touch nothing about tatooine houses :/ , i search a little to know what is happening but xd, just i found something about templates problems or string problem. But xd i dont know really what does mean, because i follow everything, 10 times every time i put something on .lua or changing something to fit the guide.... and im still can't put the dinner / barn ingame.
 
Reply
#5
Solved by moving the .tre file the first, somewhere i read that but then appear this xd

(549 s) [ObjectManager] ERROR - trying to create object with unknown objectcrc 0x74c2ed33
(549 s) [ZoneServer swgemudev] ERROR - TemplateManager::getTemplateFile exception unknown template key 0x74c2ed33
TemplateManager::getTemplateFile exception unknown template key 0x74c2ed33
??:?
??:?
/home/vagrant/workspace/Core3/MMOCoreORB/build/unix/src/../../../src/server/zone/managers/templates/TemplateManager.cpp:794 (discriminator 6)
/home/vagrant/workspace/Core3/MMOCoreORB/build/unix/src/../../../src/server/zone/managers/object/ObjectManager.cpp:818 (discriminator 1)
/home/vagrant/workspace/Core3/MMOCoreORB/build/unix/src/../../../src/server/zone/ZoneServerImplementation.cpp:480 (discriminator 3)
/home/vagrant/workspace/Core3/MMOCoreORB/build/unix/src/../../../src/autogen/server/zone/ZoneServer.cpp:376
/home/vagrant/workspace/Core3/MMOCoreORB/build/unix/src/../../../src/server/zone/managers/sui/SuiManager.cpp:638 (discriminator 1)
/home/vagrant/workspace/Core3/MMOCoreORB/build/unix/src/../../../src/server/zone/managers/sui/SuiManager.cpp:160
/home/vagrant/workspace/Core3/MMOCoreORB/build/unix/src/../../../src/server/zone/packets/ui/SuiEventNotificationCallback.h:50 (discriminator 2)
??:?
??:?
??:?
??:0
??:0
(550 s) [SuiManager] ERROR - could not create frog item: Dinner


So its a template thing problem i thought n? I modified the object_template_crc_string diner is there...
 
Reply
#6
Well since is problem related to same map xd and i give up to put diner ingame since i cant, 6 days sleeping few for messing up all the server xD and i need to do a clean install of everything... im at the same point before i start with diner, but this time i see a problem, ( it exist before, but then i was decided to do diner first) since i forgive diner ( i use vip bunker to add food buff to house xd ) the problem is nativepool resources for new planets.

I modified resourceimplementation.ccp adding all new planets, i add on scripts/manager folder resource_manager.lua all new planets and i reconfigure resource_tree.iff to all new planets.

But no flora/water/energy spawn on new planets ( metal, steel, etc... yes ) im missing something?

   
PD: i build ,start,restart, delete all db, restart, delete restart, restar & delete and all combinations i know to try to make this working.

solved time to time it was a extrange realtionship problem with my pc vs SIE... sometimes messup the database and not work properly.
 
Reply
  



Forum Jump:


Browsing: 1 Guest(s)