Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Transparency on NGE objects
#1
Trying to bring over multiple NGE objects for use in Pre-CU.

I'm having trouble with transparency on multiple objects. I'll get something that looks nearly see-through in my inventory, and is invisible when dropped.

Here's a picture of what I'm talking about:
[Image: screenShot0903_zpshmkljmnh.jpg]

I've seen this on all the Dathomir tapestries, the torn Rebel Resistance poster, the Lifeday Bunting, Lifeday Wreath, and Mandalorian Banner. Basically, things that are meant to have some areas of transparency.

Similarly, a couple of things that are meant to have "glass" areas, appear fine in the inventory but when dropped, the glass portion is invisible. These include glass shelving and a fish tank (both from object/tangible/collection/reward/).

Has anyone seen this problem, and is it fixable, or just something to do with NGE/Pre-CU incompatibility?
 
Reply
#2
I've added in fish tanks with no issues. Looks like you are missing shaders/textures
 
Reply
#3
Hmm. For the fishtank in particular, here are all the files I identified regarding its appearance:

object/tangible/collection/reward/fish_tank_reward.iff
appearance/frn_all_fishtank.apt
appearance/lod/frn_all_fishtank.lod
mesh/frn_all_fishtank_l2.msh
mesh/frn_all_fishtank_l1.msh
mesh/frn_all_fishtank_l0.msh
shader/frn_all_fishtank_as8.sht
shader/frn_all_fishtank_sm_as8.sht
texture/frn_all_fishtank.dds
effect\a_envmask.eft
texture/frn_all_fishtank_sm.dds
effect\a_simple.eft
vertex_program/a_envmask_vs20_for_ps20.vsh
vertex_program/a_envmask_vs11_for_ps11.vsh
vertex_program/a_simple_vs20_for_ps20.vsh
vertex_program/a_simple_vs11.vsh
pixel_program/a_envmask_pp_ps20.psh
pixel_program/a_envmask_ps11.psh
pixel_program/a_simple_pp_ps20.psh
pixel_program/a_simple_ps11.psh
vertex_program/include/functions.inc
vertex_program/include/vertex_shader_constants.inc
pixel_program/include/pixel_shader_constants.inc
pixel_program/include/functions.inc

The glass IS visible in the inventory icon, but not when it's dropped in a house.

This is an image I found on the web of what it's supposed to look like:
[Image: index_zpsh362pfax.jpg]
 
Reply
#4
I get what seems to be the opposite problem. I get a frame with a default waterfall texture no matter what I do (though I didnt try very hard). I cant pull the painting I want Tongue Looks like you need the frame.
 
Reply
#5
Are you trying to pull the clone trooper or grievous paintings?
 
Reply
#6
Here is something interesting - I had a number of solid-glass-having objects that were working, and now when I spawn them, no longer are (the glass is invisible when dropped, but visible in the inventory icon).

Since I haven't removed any shaders or anything out of effect, pixel_program or vertex_program, it would seem something I have added in the meantime is interfering.

So as a test, I cleared my shaders, effect, pixel_program, and vertex_program folders of everything except those files required by one of the objects I previously had working (object/tangible/saga_system/rewards/frn_fireplace.iff) and re-packed the tre. Sadly, still not working. I'm not sure what it is I've done, but I did have all of these files working, and now they are not:

object/tangible/saga_system/rewards/frn_fireplace.iff
object/tangible/tcg/series6/decorative_baby_colo_claw_fishtank.iff
object/tangible/tcg/series1/decorative_display_case_01.iff
object/tangible/tcg/series1/decorative_display_case_02.iff
object/tangible/tcg/series1/decorative_drink_dispenser.iff (the glass vials)
object/tangible/collection/reward/col_reward_hoth_meteorite_geode.iff (the glass display stand)

Hoping Timbab maybe has some knowledge on what specifically could be interfering with the rendering of glass.

All of the things with "solid glass" textures that I'm having trouble with are using a_alpha.eft or a_alpha_envmask_specmap.eft
 
Reply
#7
I was trying to pull the grievous one.
 
Reply
#8
(2015-02-17, 11:25 PM)Arioch Wrote: I was trying to pull the grievous one.

I had that problem with those 2. And only those 2.
 
Reply
#9
Sorry stacy, only just now saw this thread.

If you still need help, I'll try to take a look in the next few days!
 
Reply
#10
(2015-03-03, 12:39 AM)Timbab Wrote: Sorry stacy, only just now saw this thread.

If you still need help, I'll try to take a look in the next few days!

I sure do! I need a better understanding of what's going on. The weird thing is, the glass textures are using an eft that is pre-14.1. So I can't see why it won't work. And it's frustrating that it renders in the inventory but not in the world.

I think I've got 2 separate issues going on here - the non-rendering of glass type textures, and the almost complete transparency of things that seem like they should have an alpha map.

Here's an example of the glass issue:

About a month ago, fishtank was working fine. I have not removed anything from the tre, but I have added to it. Here it is now...

[Image: screenShot0914_zpsssj4gqtw.jpg]

And the alpha map issue has a pic in the first post.
 
Reply
  



Forum Jump:


Browsing: 1 Guest(s)